import re
regex = re.compile(r"(\d{4}-\d{2}-\d{2})Z", flags=re.MULTILINE)
test_str = "control1970-04-26Z_shifted1982-02-01_Zulu1999-09-09Z"
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)