package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d{4}-\d{2}-\d{2})Z`)
var str = `control1970-04-26Z_shifted1982-02-01_Zulu1999-09-09Z`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}