import Foundation
let pattern = #"(\d{4}-\d{2}-\d{2})Z"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"control1970-04-26Z_shifted1982-02-01_Zulu1999-09-09Z"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)