// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d{4}-\d{2}-\d{2})Z").unwrap();
let string = "control1970-04-26Z_shifted1982-02-01_Zulu1999-09-09Z";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}