const regex = /(\d{4}-\d{2}-\d{2})Z/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{4}-\\d{2}-\\d{2})Z', 'gm')
const str = `control1970-04-26Z_shifted1982-02-01_Zulu1999-09-09Z`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);