use strict;
my $str = 'control1970-04-26Z_shifted1982-02-01_Zulu1999-09-09Z';
my $regex = qr/(\d{4}-\d{2}-\d{2})Z/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";