#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(<p>[0-9]{2,8}-[0-9]{2}-[0-9]{1}</p>)"
Local $sString = "<p>inorganische arseen verbindingen</p>" & @CRLF & _
" " & @CRLF & _
" </td>" & @CRLF & _
" <td class="left top border-column border-row"> </td>" & @CRLF & _
" <td class="left top border-column border-row"> </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr class="left middle tr-rowsep odd">" & @CRLF & _
" <td class="left top border-column border-row">" & @CRLF & _
" " & @CRLF & _
" <p>asbest</p>" & @CRLF & _
" " & @CRLF & _
" </td>" & @CRLF & _
" <td class="left top border-column border-row"> </td>" & @CRLF & _
" <td class="left top border-column border-row">" & @CRLF & _
" " & @CRLF & _
" <p>1332-21-4</p>" & @CRLF & _
" " & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr class="left middle tr-rowsep even">" & @CRLF & _
" <td class="left top border-column border-row">" & @CRLF & _
" " & @CRLF & _
" <p>5-azacytidine</p>" & @CRLF & _
" " & @CRLF & _
" </td>" & @CRLF & _
" <td class="left top border-column border-row"> </td>" & @CRLF & _
" <td class="left top border-column border-row">" & @CRLF & _
" " & @CRLF & _
" <p>320-67-2</p>" & @CRLF & _
" " & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr class="left middle tr-rowsep odd">" & @CRLF & _
" <td class="left top border-column border-row">" & @CRLF & _
" " & @CRLF & _
" <p>azaserine</p>" & @CRLF & _
" " & @CRLF & _
" </td>" & @CRLF & _
" <td class="left top border-column border-row"> </td>" & @CRLF & _
" <td class="left top border-column border-row">" & @CRLF & _
" " & @CRLF & _
" <p>115-02-6</p>" & @CRLF & _
" " & @CRLF & _
" </td>" & @CRLF & _
" </tr>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")