using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<p>[0-9]{2,8}-[0-9]{2}-[0-9]{1}</p>)";
string input = @"<p>inorganische arseen verbindingen</p>
</td>
<td class=""left top border-column border-row""> </td>
<td class=""left top border-column border-row""> </td>
</tr>
<tr class=""left middle tr-rowsep odd"">
<td class=""left top border-column border-row"">
<p>asbest</p>
</td>
<td class=""left top border-column border-row""> </td>
<td class=""left top border-column border-row"">
<p>1332-21-4</p>
</td>
</tr>
<tr class=""left middle tr-rowsep even"">
<td class=""left top border-column border-row"">
<p>5-azacytidine</p>
</td>
<td class=""left top border-column border-row""> </td>
<td class=""left top border-column border-row"">
<p>320-67-2</p>
</td>
</tr>
<tr class=""left middle tr-rowsep odd"">
<td class=""left top border-column border-row"">
<p>azaserine</p>
</td>
<td class=""left top border-column border-row""> </td>
<td class=""left top border-column border-row"">
<p>115-02-6</p>
</td>
</tr>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}