const regex = new RegExp('(<p>[0-9]{2,8}-[0-9]{2}-[0-9]{1}</p>)', 'gm')
const str = `<p>inorganische arseen verbindingen</p>
</td>
<td class="left top border-column border-row"> </td>
<td class="left top border-column border-row"> </td>
</tr>
<tr class="left middle tr-rowsep odd">
<td class="left top border-column border-row">
<p>asbest</p>
</td>
<td class="left top border-column border-row"> </td>
<td class="left top border-column border-row">
<p>1332-21-4</p>
</td>
</tr>
<tr class="left middle tr-rowsep even">
<td class="left top border-column border-row">
<p>5-azacytidine</p>
</td>
<td class="left top border-column border-row"> </td>
<td class="left top border-column border-row">
<p>320-67-2</p>
</td>
</tr>
<tr class="left middle tr-rowsep odd">
<td class="left top border-column border-row">
<p>azaserine</p>
</td>
<td class="left top border-column border-row"> </td>
<td class="left top border-column border-row">
<p>115-02-6</p>
</td>
</tr>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}