import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<p>[0-9]{2,8}-[0-9]{2}-[0-9]{1}</p>)";
final String string = "<p>inorganische arseen verbindingen</p>\n"
+ " \n"
+ " </td>\n"
+ " <td class=\"left top border-column border-row\"> </td>\n"
+ " <td class=\"left top border-column border-row\"> </td>\n"
+ " </tr>\n"
+ " <tr class=\"left middle tr-rowsep odd\">\n"
+ " <td class=\"left top border-column border-row\">\n"
+ " \n"
+ " <p>asbest</p>\n"
+ " \n"
+ " </td>\n"
+ " <td class=\"left top border-column border-row\"> </td>\n"
+ " <td class=\"left top border-column border-row\">\n"
+ " \n"
+ " <p>1332-21-4</p>\n"
+ " \n"
+ " </td>\n"
+ " </tr>\n"
+ " <tr class=\"left middle tr-rowsep even\">\n"
+ " <td class=\"left top border-column border-row\">\n"
+ " \n"
+ " <p>5-azacytidine</p>\n"
+ " \n"
+ " </td>\n"
+ " <td class=\"left top border-column border-row\"> </td>\n"
+ " <td class=\"left top border-column border-row\">\n"
+ " \n"
+ " <p>320-67-2</p>\n"
+ " \n"
+ " </td>\n"
+ " </tr>\n"
+ " <tr class=\"left middle tr-rowsep odd\">\n"
+ " <td class=\"left top border-column border-row\">\n"
+ " \n"
+ " <p>azaserine</p>\n"
+ " \n"
+ " </td>\n"
+ " <td class=\"left top border-column border-row\"> </td>\n"
+ " <td class=\"left top border-column border-row\">\n"
+ " \n"
+ " <p>115-02-6</p>\n"
+ " \n"
+ " </td>\n"
+ " </tr>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}