# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<p>[0-9]{2,8}-[0-9]{2}-[0-9]{1}</p>)"
test_str = ("<p>inorganische arseen verbindingen</p>\n"
" \n"
" </td>\n"
" <td class=\"left top border-column border-row\"> </td>\n"
" <td class=\"left top border-column border-row\"> </td>\n"
" </tr>\n"
" <tr class=\"left middle tr-rowsep odd\">\n"
" <td class=\"left top border-column border-row\">\n"
" \n"
" <p>asbest</p>\n"
" \n"
" </td>\n"
" <td class=\"left top border-column border-row\"> </td>\n"
" <td class=\"left top border-column border-row\">\n"
" \n"
" <p>1332-21-4</p>\n"
" \n"
" </td>\n"
" </tr>\n"
" <tr class=\"left middle tr-rowsep even\">\n"
" <td class=\"left top border-column border-row\">\n"
" \n"
" <p>5-azacytidine</p>\n"
" \n"
" </td>\n"
" <td class=\"left top border-column border-row\"> </td>\n"
" <td class=\"left top border-column border-row\">\n"
" \n"
" <p>320-67-2</p>\n"
" \n"
" </td>\n"
" </tr>\n"
" <tr class=\"left middle tr-rowsep odd\">\n"
" <td class=\"left top border-column border-row\">\n"
" \n"
" <p>azaserine</p>\n"
" \n"
" </td>\n"
" <td class=\"left top border-column border-row\"> </td>\n"
" <td class=\"left top border-column border-row\">\n"
" \n"
" <p>115-02-6</p>\n"
" \n"
" </td>\n"
" </tr>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.