use strict;
my $str = '<p>inorganische arseen verbindingen</p>
</td>
<td class="left top border-column border-row"> </td>
<td class="left top border-column border-row"> </td>
</tr>
<tr class="left middle tr-rowsep odd">
<td class="left top border-column border-row">
<p>asbest</p>
</td>
<td class="left top border-column border-row"> </td>
<td class="left top border-column border-row">
<p>1332-21-4</p>
</td>
</tr>
<tr class="left middle tr-rowsep even">
<td class="left top border-column border-row">
<p>5-azacytidine</p>
</td>
<td class="left top border-column border-row"> </td>
<td class="left top border-column border-row">
<p>320-67-2</p>
</td>
</tr>
<tr class="left middle tr-rowsep odd">
<td class="left top border-column border-row">
<p>azaserine</p>
</td>
<td class="left top border-column border-row"> </td>
<td class="left top border-column border-row">
<p>115-02-6</p>
</td>
</tr>';
my $regex = qr~(<p>[0-9]{2,8}-[0-9]{2}-[0-9]{1}</p>)~mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}