import Foundation
let pattern = #"(<p>[0-9]{2,8}-[0-9]{2}-[0-9]{1}</p>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<p>inorganische arseen verbindingen</p>
</td>
<td class="left top border-column border-row"> </td>
<td class="left top border-column border-row"> </td>
</tr>
<tr class="left middle tr-rowsep odd">
<td class="left top border-column border-row">
<p>asbest</p>
</td>
<td class="left top border-column border-row"> </td>
<td class="left top border-column border-row">
<p>1332-21-4</p>
</td>
</tr>
<tr class="left middle tr-rowsep even">
<td class="left top border-column border-row">
<p>5-azacytidine</p>
</td>
<td class="left top border-column border-row"> </td>
<td class="left top border-column border-row">
<p>320-67-2</p>
</td>
</tr>
<tr class="left middle tr-rowsep odd">
<td class="left top border-column border-row">
<p>azaserine</p>
</td>
<td class="left top border-column border-row"> </td>
<td class="left top border-column border-row">
<p>115-02-6</p>
</td>
</tr>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)