// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(<p>[0-9]{2,8}-[0-9]{2}-[0-9]{1}</p>)").unwrap();
let string = "<p>inorganische arseen verbindingen</p>
</td>
<td class=\"left top border-column border-row\"> </td>
<td class=\"left top border-column border-row\"> </td>
</tr>
<tr class=\"left middle tr-rowsep odd\">
<td class=\"left top border-column border-row\">
<p>asbest</p>
</td>
<td class=\"left top border-column border-row\"> </td>
<td class=\"left top border-column border-row\">
<p>1332-21-4</p>
</td>
</tr>
<tr class=\"left middle tr-rowsep even\">
<td class=\"left top border-column border-row\">
<p>5-azacytidine</p>
</td>
<td class=\"left top border-column border-row\"> </td>
<td class=\"left top border-column border-row\">
<p>320-67-2</p>
</td>
</tr>
<tr class=\"left middle tr-rowsep odd\">
<td class=\"left top border-column border-row\">
<p>azaserine</p>
</td>
<td class=\"left top border-column border-row\"> </td>
<td class=\"left top border-column border-row\">
<p>115-02-6</p>
</td>
</tr>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}