package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(<p>[0-9]{2,8}-[0-9]{2}-[0-9]{1}</p>)`)
var str = `<p>inorganische arseen verbindingen</p>
</td>
<td class="left top border-column border-row"> </td>
<td class="left top border-column border-row"> </td>
</tr>
<tr class="left middle tr-rowsep odd">
<td class="left top border-column border-row">
<p>asbest</p>
</td>
<td class="left top border-column border-row"> </td>
<td class="left top border-column border-row">
<p>1332-21-4</p>
</td>
</tr>
<tr class="left middle tr-rowsep even">
<td class="left top border-column border-row">
<p>5-azacytidine</p>
</td>
<td class="left top border-column border-row"> </td>
<td class="left top border-column border-row">
<p>320-67-2</p>
</td>
</tr>
<tr class="left middle tr-rowsep odd">
<td class="left top border-column border-row">
<p>azaserine</p>
</td>
<td class="left top border-column border-row"> </td>
<td class="left top border-column border-row">
<p>115-02-6</p>
</td>
</tr>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}