# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\w{1,2}-\d{1,4})(\w)\\/(\w)\\/(\w)/\1\2\n\1\3\n\1\4/gm;t' <<< "D-1150A/B/C
"