# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\w{1,2}-\d{1,4})(\w)\/(\w)\/(\w)"
test_str = ("D-1150A/B/C\n")
subst = "\\1\\2\\n\\1\\3\\n\\1\\4"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.