use strict;
my $str = 'D-1150A/B/C
';
my $regex = qr/(\w{1,2}-\d{1,4})(\w)\/(\w)\/(\w)/mp;
my $subst = '\\1\\2\\n\\1\\3\\n\\1\\4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";