import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w{1,2}-\\d{1,4})(\\w)\\/(\\w)\\/(\\w)";
final String string = "D-1150A/B/C\n";
final String subst = "\\1\\2\\n\\1\\3\\n\\1\\4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}