// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\w{1,2}-\d{1,4})(\w)\/(\w)\/(\w)").unwrap();
let string = "D-1150A/B/C
";
let substitution = "\\1\\2\\n\\1\\3\\n\\1\\4";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}