const regex = /(\w{1,2}-\d{1,4})(\w)\/(\w)\/(\w)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w{1,2}-\\d{1,4})(\\w)\\\/(\\w)\\\/(\\w)', 'gm')
const str = `D-1150A/B/C
`;
const subst = `\1\2\n\1\3\n\1\4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);