$re = '/(\w{1,2}-\d{1,4})(\w)\/(\w)\/(\w)/m';
$str = 'D-1150A/B/C
';
$subst = "\1\2\n\1\3\n\1\4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;