# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\bor\b(?=([^\"]|\"[^\"]+\")+$)/|/g;t' <<< "\"Supermajority Vote for State Taxes or fees\" or taxes or \"ssd or ffF\"
\"Supermajority Vote for State Taxes or fees\" | taxes | \"ssd or ffF\"
"