import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bor\\b(?=([^\\\"]|\\\"[^\\\"]+\\\")+$)";
final String string = "\"Supermajority Vote for State Taxes or fees\" or taxes or \"ssd or ffF\"\n"
+ "\"Supermajority Vote for State Taxes or fees\" | taxes | \"ssd or ffF\"\n";
final String subst = "|";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}