const regex = new RegExp('\\bor\\b(?=([^\\"]|\\"[^\\"]+\\")+$)', 'g')
const str = `"Supermajority Vote for State Taxes or fees" or taxes or "ssd or ffF"
"Supermajority Vote for State Taxes or fees" | taxes | "ssd or ffF"
`;
const subst = `|`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);