$re = '/\bor\b(?=([^\"]|\"[^\"]+\")+$)/';
$str = '"Supermajority Vote for State Taxes or fees" or taxes or "ssd or ffF"
"Supermajority Vote for State Taxes or fees" | taxes | "ssd or ffF"
';
$subst = "|";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;