re = /\bor\b(?=([^\"]|\"[^\"]+\")+$)/
str = '"Supermajority Vote for State Taxes or fees" or taxes or "ssd or ffF"
"Supermajority Vote for State Taxes or fees" | taxes | "ssd or ffF"
'
subst = '|'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result