using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bor\b(?=([^\""]|\""[^\""]+\"")+$)";
string substitution = @"|";
string input = @"""Supermajority Vote for State Taxes or fees"" or taxes or ""ssd or ffF""
""Supermajority Vote for State Taxes or fees"" | taxes | ""ssd or ffF""
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}