import Foundation
let pattern = #"\bor\b(?=([^\"]|\"[^\"]+\")+$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
"Supermajority Vote for State Taxes or fees" or taxes or "ssd or ffF"
"Supermajority Vote for State Taxes or fees" | taxes | "ssd or ffF"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"|"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)