# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d+д)?(\d+ч)?(\d+м)?(\d+с)?//gi;t' <<< " 25д10ч3м10с
25д0ч3м10с
15м30с
10д5с
10ч
15м
30с
25д3м11с"