import re
regex = re.compile(r"(\d+д)?(\d+ч)?(\d+м)?(\d+с)?", flags=re.IGNORECASE)
test_str = (" 25д10ч3м10с\n"
" 25д0ч3м10с\n"
" 15м30с\n"
" 10д5с\n"
" 10ч\n"
" 15м\n"
" 30с\n"
" 25д3м11с")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)