import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+д)?(\\d+ч)?(\\d+м)?(\\d+с)?";
final String string = " 25д10ч3м10с\n"
+ " 25д0ч3м10с\n"
+ " 15м30с\n"
+ " 10д5с\n"
+ " 10ч\n"
+ " 15м\n"
+ " 30с\n"
+ " 25д3м11с";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}