#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i)(\d+д)?(\d+ч)?(\d+м)?(\d+с)?"
Local $sString = " 25д10ч3м10с" & @CRLF & _
" 25д0ч3м10с" & @CRLF & _
" 15м30с" & @CRLF & _
" 10д5с" & @CRLF & _
" 10ч" & @CRLF & _
" 15м" & @CRLF & _
" 30с" & @CRLF & _
" 25д3м11с"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)