re = /(\d+д)?(\d+ч)?(\d+м)?(\d+с)?/i
str = ' 25д10ч3м10с
25д0ч3м10с
15м30с
10д5с
10ч
15м
30с
25д3м11с'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result