import Foundation
let pattern = #"(\d+д)?(\d+ч)?(\d+м)?(\d+с)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
25д10ч3м10с
25д0ч3м10с
15м30с
10д5с
10ч
15м
30с
25д3м11с
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)