use strict;
my $str = ' 25д10ч3м10с
25д0ч3м10с
15м30с
10д5с
10ч
15м
30с
25д3м11с';
my $regex = qr/(\d+д)?(\d+ч)?(\d+м)?(\d+с)?/ip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";