const regex = /(\d+д)?(\d+ч)?(\d+м)?(\d+с)?/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+д)?(\\d+ч)?(\\d+м)?(\\d+с)?', 'gi')
const str = ` 25д10ч3м10с
25д0ч3м10с
15м30с
10д5с
10ч
15м
30с
25д3м11с`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);