package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(\d+д)?(\d+ч)?(\d+м)?(\d+с)?`)
var str = ` 25д10ч3м10с
25д0ч3м10с
15м30с
10д5с
10ч
15м
30с
25д3м11с`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}