#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)^(([^\n\r.]*).*)(?:(?:\r?\n|\r)\2.*)*"
Local $sString = "This is test string for my app. d" & @CRLF & _
"This is test string for my app." & @CRLF & _
"This is test string for my app. abcd" & @CRLF & _
"This is test string for my app." & @CRLF & _
"This is test string for my app." & @CRLF & _
"This is test string for my app." & @CRLF & _
"This is test string for my app. d" & @CRLF & _
"This is test string for my app." & @CRLF & _
"This is test string for my app." & @CRLF & _
"This is another string."
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)