import re
regex = re.compile(r"^(([^\n\r.]*).*)(?:(?:\r?\n|\r)\2.*)*", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("This is test string for my app. d\n"
"This is test string for my app.\n"
"This is test string for my app. abcd\n"
"This is test string for my app.\n"
"This is test string for my app.\n"
"This is test string for my app.\n"
"This is test string for my app. d\n"
"This is test string for my app.\n"
"This is test string for my app.\n"
"This is another string.")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)