import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(([^\\n\\r.]*).*)(?:(?:\\r?\\n|\\r)\\2.*)*";
final String string = "This is test string for my app. d\n"
+ "This is test string for my app.\n"
+ "This is test string for my app. abcd\n"
+ "This is test string for my app.\n"
+ "This is test string for my app.\n"
+ "This is test string for my app.\n"
+ "This is test string for my app. d\n"
+ "This is test string for my app.\n"
+ "This is test string for my app.\n"
+ "This is another string.";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}