const regex = new RegExp('^(([^\\n\\r.]*).*)(?:(?:\\r?\\n|\\r)\\2.*)*', 'gmi')
const str = `This is test string for my app. d
This is test string for my app.
This is test string for my app. abcd
This is test string for my app.
This is test string for my app.
This is test string for my app.
This is test string for my app. d
This is test string for my app.
This is test string for my app.
This is another string.`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);