using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(([^\n\r.]*).*)(?:(?:\r?\n|\r)\2.*)*";
string substitution = @"\1";
string input = @"This is test string for my app. d
This is test string for my app.
This is test string for my app. abcd
This is test string for my app.
This is test string for my app.
This is test string for my app.
This is test string for my app. d
This is test string for my app.
This is test string for my app.
This is another string.";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}