re = /^(([^\n\r.]*).*)(?:(?:\r?\n|\r)\2.*)*/mi
str = 'This is test string for my app. d
This is test string for my app.
This is test string for my app. abcd
This is test string for my app.
This is test string for my app.
This is test string for my app.
This is test string for my app. d
This is test string for my app.
This is test string for my app.
This is another string.'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result