# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\[id(\d{1,20})\|(.*?)\]/<a href="\/users\/$1">$2<\/a>/g;t' <<< "[id215554550|Евгений Маркин]"