const regex = /\[id(\d{1,20})\|(.*?)\]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[id(\\d{1,20})\\|(.*?)\\]', 'g')
const str = `[id215554550|Евгений Маркин]`;
const subst = `<a href="/users/$1">$2</a>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);