$re = '/\[id(\d{1,20})\|(.*?)\]/';
$str = '[id215554550|Евгений Маркин]';
$subst = "<a href=\"/users/$1\">$2</a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;