using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[id(\d{1,20})\|(.*?)\]";
string substitution = @"<a href=""/users/$1"">$2</a>";
string input = @"[id215554550|Евгений Маркин]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}