package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[id(\d{1,20})\|(.*?)\]`)
var str = `[id215554550|Евгений Маркин]`
var substitution = "<a href="/users/$1">$2</a>"
fmt.Println(re.ReplaceAllString(str, substitution))
}