re = /\[id(\d{1,20})\|(.*?)\]/
str = '[id215554550|Евгений Маркин]'
subst = '<a href="/users/$1">$2</a>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result